I already searched answer for this question and checked Bartek Chanda answer, but not working with me. I have debian 9.13 and already done what Bartek Chanda answered, but not working.
Still got this error:
php7.4-curl : Depends: php7.4-common (= 7.4.18-2+ubuntu21.04.1+deb.sury.org+3) but 7.4.12-3+0~20201103.32+debian9~1.gbpa97e22 is to be installed Depends: libcurl4 (>= 7.56.1) but it is not installable E: Unable to correct problems, you have held broken packages.
You say you have Debian 9 but you appear to have added an apt source intended for Ubuntu 21.04. Remove it and replace it with the correct apt source, then try again.
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.