package docker-ce requires >= 1.4.1, but none of the providers can be installed

martin asked:

I had this problem this morning for both update / upgrade on red hat (Linux 4.18.0-240.1.1.el8_3.x86_64), not sure what to do. Sounds like yum is completely stuck because of this.

$ sudo yum update
Updating Subscription Management repositories.
Last metadata expiration check: 2:40:27 ago on Wed 16 Dec 2020 07:53:10 AM CST.
 Problem: package docker-ce-3:20.10.1-3.el7.x86_64 requires >= 1.4.1, but none of the providers can be installed
  - cannot install the best update candidate for package docker-ce-3:19.03.14-3.el7.x86_64
  - package is filtered out by modular filtering
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

My answer:

You’re trying to install packages built for EL 7 on EL 8. This isn’t going to work, and it’s not clear how you managed to do that in the first place. The correct Docker CE repo file gets the correct package versions for your RHEL release, and you should use it instead of whatever custom repo you have used.

View the full question and any other answers on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.