Resetting the TPM module on my motherboard?

Rail24 asked:

I’ve got a TPM set up on a motherboard, but the motherboard has now been swapped, and the HDD is still the same.

Would like to basically reset everything to factory defaults, but the HDD is encrypted and I can’t seem to reset the TPM.

No matter what I always end up on: "Please enter passphrase for disk KINGSTON:"

What I’ve looked at:

The BIOS setting has:

-> Advanced -> Trusted Computing -> Pending Operation -> TPM Clear

Which I’ve tried, but hasn’t been successful.

There’s also a pin on the motherboard for "Security Override Jumper".

I’ve tried swapping it which has set it to ME Recovery Mode, and then tried to TPM Clear option, but that hasn’t done anything either.

I think I may be missing something obvious. I want to both reset the TPM encryption on the HDD and immediately run a new install script…

I would think that resetting the TPM would also kind of force the HDD to be cleared of all data.

Any ideas?

My answer:


If you cleared the TPM while it still had the hard drive password in it, then it is lost forever.

A vendor-specific tool might be able to wipe the drive (and its password along with it) but this isn’t very common. Most likely you will have to bin the drive.


View the full question and any other answers on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.