How to install pam_mount on RHEL 8?

francisaugusto asked:

I’m trying to install pam_mount on RHEL8 but keep getting this:

rror:
 Problem: package pam_mount-2.16-10.el8.x86_64 requires hxtools, but none of the providers can be installed
  - conflicting requests
  - nothing provides perl(encoding) needed by hxtools-20150304-10.el8.x86_64
(try to add '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

Perl is indeed installed:

# perl -v

This is perl 5, version 26, subversion 3 (v5.26.3) built for x86_64-linux-thread-multi
(with 51 registered patches, see perl -V for more detail)

Any tips on how to do it?

My answer:


There are two possibilities here:

  1. You have disabled the repository rhel-8-for-x86_64-appstream-rpms. The dependencies you need are in this repo.

  2. Alternately, your RHEL subscription is expired or not active. An active RHEL subscription is required to install packages.


View the full question and any other answers on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.