Installation OpenLiteSpeed Web Server on Amazon Linux (RHEL)

anskibenko asked:

I’m just trying to install OLS on my Amazon Linux 2 instance, but i received errors at first and all last steps. Here is the explaination about:

  1. When i added recommended by guide repository, i receive error:

     failure: repodata/repomd.xml from litespeed: [Errno 256] No more mirrors to try.
    

    http://rpms.litespeedtech.com/centos/8/x86_64/repodata/x86_64/repodata/repomd.xml: [Errno 14] HTTP Error 404 – Not Found

To fix it, i just replace $releaseserver to 8 (as i can see at http://rpms.litespeedtech.com/centos/) at link http://rpms.litespeedtech.com/centos/$releasever/$basearch/
and… it works!
But after that, when i trying to install, i receive these dependency errors:

Loaded plugins: langpacks, priorities, update-motd
191 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package lsphp73.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: lsphp73-common(x86-64) = 7.3.18-1.el8 for package: lsphp73-7.3.18-1.el8.x86_64
--> Processing Dependency: libssl.so.1.1(OPENSSL_1_1_0)(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
--> Processing Dependency: libcrypto.so.1.1(OPENSSL_1_1_0)(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
--> Processing Dependency: libssl.so.1.1()(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
--> Processing Dependency: libcrypto.so.1.1()(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
--> Processing Dependency: libargon2.so.1()(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
---> Package openlitespeed.x86_64 0:1.6.14-1.el8 will be installed
--> Processing Dependency: lsphp73-xml for package: openlitespeed-1.6.14-1.el8.x86_64
--> Processing Dependency: lsphp73-process for package: openlitespeed-1.6.14-1.el8.x86_64
--> Processing Dependency: lsphp73-pdo for package: openlitespeed-1.6.14-1.el8.x86_64
--> Processing Dependency: lsphp73-opcache for package: openlitespeed-1.6.14-1.el8.x86_64
--> Processing Dependency: lsphp73-mysqlnd for package: openlitespeed-1.6.14-1.el8.x86_64
--> Processing Dependency: lsphp73-mcrypt for package: openlitespeed-1.6.14-1.el8.x86_64
--> Processing Dependency: lsphp73-mbstring for package: openlitespeed-1.6.14-1.el8.x86_64
--> Processing Dependency: lsphp73-imap for package: openlitespeed-1.6.14-1.el8.x86_64
--> Processing Dependency: lsphp73-gd for package: openlitespeed-1.6.14-1.el8.x86_64
--> Processing Dependency: libnsl for package: openlitespeed-1.6.14-1.el8.x86_64
--> Running transaction check
---> Package lsphp73.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
--> Processing Dependency: libargon2.so.1()(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
---> Package lsphp73-common.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-common-7.3.18-1.el8.x86_64
---> Package lsphp73-gd.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libpng16.so.16(PNG16_0)(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
--> Processing Dependency: libwebp.so.7()(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
--> Processing Dependency: libpng16.so.16()(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
--> Processing Dependency: libXpm.so.4()(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
--> Processing Dependency: libX11.so.6()(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
---> Package lsphp73-imap.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc-client.so.2007()(64bit) for package: lsphp73-imap-7.3.18-1.el8.x86_64
---> Package lsphp73-mbstring.x86_64 0:7.3.18-1.el8 will be installed
---> Package lsphp73-mysqlnd.x86_64 0:7.3.18-1.el8 will be installed
---> Package lsphp73-opcache.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-opcache-7.3.18-1.el8.x86_64
---> Package lsphp73-pdo.x86_64 0:7.3.18-1.el8 will be installed
---> Package lsphp73-pecl-mcrypt.x86_64 0:1.0.3-1.el8.7.3 will be installed
--> Processing Dependency: libmcrypt.so.4()(64bit) for package: lsphp73-pecl-mcrypt-1.0.3-1.el8.7.3.x86_64
---> Package lsphp73-process.x86_64 0:7.3.18-1.el8 will be installed
---> Package lsphp73-xml.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.24)(64bit) for package: lsphp73-xml-7.3.18-1.el8.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.22)(64bit) for package: lsphp73-xml-7.3.18-1.el8.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.18)(64bit) for package: lsphp73-xml-7.3.18-1.el8.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.13)(64bit) for package: lsphp73-xml-7.3.18-1.el8.x86_64
--> Processing Dependency: libxslt.so.1(LIBXML2_1.0.11)(64bit) for package: lsphp73-xml-7.3.18-1.el8.x86_64
--> Processing Dependency: libxslt.so.1()(64bit) for package: lsphp73-xml-7.3.18-1.el8.x86_64
--> Processing Dependency: libexslt.so.0()(64bit) for package: lsphp73-xml-7.3.18-1.el8.x86_64
---> Package openlitespeed.x86_64 0:1.6.14-1.el8 will be installed
--> Processing Dependency: libnsl for package: openlitespeed-1.6.14-1.el8.x86_64
---> Package openssl11-libs.x86_64 1:1.1.1c-3.amzn2.0.1 will be installed
--> Running transaction check
---> Package libX11.x86_64 0:1.6.7-2.amzn2 will be installed
--> Processing Dependency: libX11-common >= 1.6.7-2.amzn2 for package: libX11-1.6.7-2.amzn2.x86_64
--> Processing Dependency: libxcb.so.1()(64bit) for package: libX11-1.6.7-2.amzn2.x86_64
---> Package libXpm.x86_64 0:3.5.12-1.amzn2.0.2 will be installed
---> Package libc-client.x86_64 0:2007f-16.el7 will be installed
---> Package libmcrypt.x86_64 0:2.5.8-13.el7 will be installed
---> Package libxslt.x86_64 0:1.1.28-5.amzn2.0.2 will be installed
---> Package lsphp73.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
--> Processing Dependency: libargon2.so.1()(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
---> Package lsphp73-common.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-common-7.3.18-1.el8.x86_64
---> Package lsphp73-gd.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libpng16.so.16(PNG16_0)(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
--> Processing Dependency: libwebp.so.7()(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
--> Processing Dependency: libpng16.so.16()(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
---> Package lsphp73-opcache.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-opcache-7.3.18-1.el8.x86_64
---> Package openlitespeed.x86_64 0:1.6.14-1.el8 will be installed
--> Processing Dependency: libnsl for package: openlitespeed-1.6.14-1.el8.x86_64
--> Running transaction check
---> Package libX11-common.noarch 0:1.6.7-2.amzn2 will be installed
---> Package libxcb.x86_64 0:1.12-1.amzn2.0.2 will be installed
--> Processing Dependency: libXau.so.6()(64bit) for package: libxcb-1.12-1.amzn2.0.2.x86_64
---> Package lsphp73.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
--> Processing Dependency: libargon2.so.1()(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
---> Package lsphp73-common.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-common-7.3.18-1.el8.x86_64
---> Package lsphp73-gd.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libpng16.so.16(PNG16_0)(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
--> Processing Dependency: libwebp.so.7()(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
--> Processing Dependency: libpng16.so.16()(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
---> Package lsphp73-opcache.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-opcache-7.3.18-1.el8.x86_64
---> Package openlitespeed.x86_64 0:1.6.14-1.el8 will be installed
--> Processing Dependency: libnsl for package: openlitespeed-1.6.14-1.el8.x86_64
--> Running transaction check
---> Package libXau.x86_64 0:1.0.8-2.1.amzn2.0.2 will be installed
---> Package lsphp73.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
--> Processing Dependency: libargon2.so.1()(64bit) for package: lsphp73-7.3.18-1.el8.x86_64
---> Package lsphp73-common.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-common-7.3.18-1.el8.x86_64
---> Package lsphp73-gd.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libpng16.so.16(PNG16_0)(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
--> Processing Dependency: libwebp.so.7()(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
--> Processing Dependency: libpng16.so.16()(64bit) for package: lsphp73-gd-7.3.18-1.el8.x86_64
---> Package lsphp73-opcache.x86_64 0:7.3.18-1.el8 will be installed
--> Processing Dependency: libc.so.6(GLIBC_2.27)(64bit) for package: lsphp73-opcache-7.3.18-1.el8.x86_64
---> Package openlitespeed.x86_64 0:1.6.14-1.el8 will be installed
--> Processing Dependency: libnsl for package: openlitespeed-1.6.14-1.el8.x86_64
--> Finished Dependency Resolution
Error: Package: lsphp73-opcache-7.3.18-1.el8.x86_64 (litespeed)
           Requires: libc.so.6(GLIBC_2.27)(64bit)
Error: Package: lsphp73-7.3.18-1.el8.x86_64 (litespeed)
           Requires: libargon2.so.1()(64bit)
Error: Package: lsphp73-gd-7.3.18-1.el8.x86_64 (litespeed)
           Requires: libwebp.so.7()(64bit)
Error: Package: openlitespeed-1.6.14-1.el8.x86_64 (litespeed)
           Requires: libnsl
Error: Package: lsphp73-common-7.3.18-1.el8.x86_64 (litespeed)
           Requires: libc.so.6(GLIBC_2.27)(64bit)
Error: Package: lsphp73-gd-7.3.18-1.el8.x86_64 (litespeed)
           Requires: libpng16.so.16(PNG16_0)(64bit)
Error: Package: lsphp73-7.3.18-1.el8.x86_64 (litespeed)
           Requires: libc.so.6(GLIBC_2.27)(64bit)
Error: Package: lsphp73-gd-7.3.18-1.el8.x86_64 (litespeed)
           Requires: libpng16.so.16()(64bit)
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest

I have no idea how to fix it.
Thanks to your reply.

My answer:


You are trying to install packages for RHEL/CentOS on Amazon Linux 2. These packages are not compatible, as Amazon Linux 2 is not compatible with RHEL/CentOS and will not run software packaged for RHEL/CentOS except by sheer accident.

To resolve the problem, use CentOS 8 or RHEL 8, the correct distributions for the package you are trying to install. Do not use Amazon Linux.


View the full question and any other answers on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.