Not able to install docker on redhat

Uday Kiran Reddy asked:

I searched for many links, they are showing only for centos even though the title is for RHEL also.

My OS details:

cat /etc/redhat-release

Red Hat Enterprise Linux Server release 7.4 (Maipo)

uname -r

3.10.0-693.58.1.el7.x86_64

I ran this to add repo

sudo yum-config-manager --add-repo https://download.docker.com/linux/rhel/docker-ce.repo

THen this

sudo yum install docker-ce

But giving this error.

Loaded plugins: langpacks, product-id, search-disabled-repos
https://download.docker.com/linux/rhel/7/x86_64/stable/repodata/repomd.xml:
[Errno 14] HTTPS Error 404 – Not Found Trying other mirror. To address
this issue please refer to the below knowledge base article

https://access.redhat.com/articles/1320623

If above article doesn’t help to resolve this issue please open a
ticket with Red Hat Support.

rhel-7-server-rpms
| 3.4 kB 00:00:00 rhui-microsoft-azure-rhel7-eus
| 2.1 kB 00:00:00 rhui-rhel-7-server-dotnet-rhui-rpms
| 2.3 kB 00:00:00 rhui-rhel-7-server-rhui-eus-optional-rpms
| 1.8 kB 00:00:00 rhui-rhel-7-server-rhui-eus-rpms
| 2.0 kB 00:00:00 rhui-rhel-7-server-rhui-eus-supplementary-rpms
| 2.0 kB 00:00:00 rhui-rhel-7-server-rhui-rh-common-rpms
| 2.1 kB 00:00:00 rhui-rhel-server-rhui-rhscl-7-rpms
| 2.0 kB 00:00:00 Resolving Dependencies
–> Running transaction check
—> Package docker-ce.x86_64 3:19.03.12-3.el7 will be installed
–> Processing Dependency: container-selinux >= 2:2.74 for package: 3:docker-ce-19.03.12-3.el7.x86_64
–> Processing Dependency: containerd.io >= 1.2.2-3 for package: 3:docker-ce-19.03.12-3.el7.x86_64
–> Processing Dependency: docker-ce-cli for package: 3:docker-ce-19.03.12-3.el7.x86_64
–> Running transaction check
—> Package containerd.io.x86_64 0:1.2.13-3.2.el7 will be installed
–> Processing Dependency: container-selinux >= 2:2.74 for package: containerd.io-1.2.13-3.2.el7.x86_64
—> Package docker-ce.x86_64 3:19.03.12-3.el7 will be installed
–> Processing Dependency: container-selinux >= 2:2.74 for package: 3:docker-ce-19.03.12-3.el7.x86_64
—> Package docker-ce-cli.x86_64 1:19.03.12-3.el7 will be installed
–> Finished Dependency Resolution Error: Package: containerd.io-1.2.13-3.2.el7.x86_64 (docker-ce-stable)
Requires: container-selinux >= 2:2.74 Error: Package: 3:docker-ce-19.03.12-3.el7.x86_64 (docker-ce-stable)
Requires: container-selinux >= 2:2.74
********************************************************************** yum can be configured to try to resolve such errors by temporarily
enabling disabled repos and searching for missing dependencies. To
enable this functionality please set ‘notify_only=0’ in
/etc/yum/pluginconf.d/search-disabled-repos.conf


Error: Package: containerd.io-1.2.13-3.2.el7.x86_64 (docker-ce-stable)
Requires: container-selinux >= 2:2.74 Error: Package: 3:docker-ce-19.03.12-3.el7.x86_64 (docker-ce-stable)
Requires: container-selinux >= 2:2.74 You could try using –skip-broken to work around the problem You could try running: rpm -Va –nofiles –nodigest

Please suggest.

My answer:


Docker CE currently requires RHEL/CentOS 7.6 or higher. You will need to upgrade the OS from 7.4 before continuing.


View the full question and any other answers on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.