CentOS 6.10 upgrade to CentOS 7.x

Meraj Rasool asked:

I have a server running CentOS release 6.10 (Final). I would like to upgrade this to latest CentOS 7.x release. To do this, when I am trying to install upgrade tools to help start with upgrade:

sudo yum install redhat-upgrade-tool preupgrade-assistant-contents

It is giving many errors e.g.

Error: Package: python34-3.4.10-1.el7.x86_64 (epel)
Requires: libpthread.so.0()(64bit)
Error: Package: php-common-5.6.40-9.el7.remi.x86_64 (remi-php56)
Requires: libpthread.so.0(GLIBC_2.2.5)(64bit)
Error: Package: php-cli-5.6.40-9.el7.remi.x86_64 (remi-php56)
Requires: libstdc++.so.6()(64bit)
Error: Package: php-cli-5.6.40-9.el7.remi.x86_64 (remi-php56)
Requires: ld-linux-x86-64.so.2()(64bit)
Error: Package: python34-libs-3.4.10-1.el7.x86_64 (epel)
Requires: libreadline.so.6()(64bit)
Error: Package: libdb4-utils-4.8.30-13.el7.x86_64 (epel)
Requires: libpthread.so.0(GLIBC_2.2.5)(64bit)…..

The list is quite large and I am not sure why is it giving this error because I continued to keep this server updated with latest updates from its own repo and still I am getting these errors.

Can anyone look into this and let me know if I am missing something here?

Thanks.

My answer:


You have an obsolete PHP version installed, which is blocking your CentOS upgrade.

To resolve the problem, upgrade to a Remi repository containing a current PHP version. Then try the CentOS 6-7 upgrade again.


View the full question and any other answers on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.