error while installing perl-Moose on red hat linux

Santosh Pillai asked:

I am seeing the errors below while installing perl-moose using command yum install perl-Moose

Can someone please help me with commands on how to install these dependencies?
Thanks in advance

Error: Package: perl-Moose-2.1005-1.el7.x86_64 (epel)
           Requires: perl(Dist::CheckConflicts) >= 0.02
Error: Package: perl-Eval-Closure-0.08-4.el7.noarch (epel)
           Requires: perl(Sub::Exporter)
Error: Package: perl-Sub-Exporter-Progressive-0.001011-1.el7.noarch (epel)
           Requires: perl(Sub::Exporter)
Error: Package: perl-Moose-2.1005-1.el7.x86_64 (epel)
           Requires: perl(Sub::Exporter)
Error: Package: perl-Moose-2.1005-1.el7.x86_64 (epel)
           Requires: perl(Sub::Exporter) >= 0.980
Error: Package: perl-Devel-PartialDump-0.15-8.el7.noarch (epel)
           Requires: perl(Sub::Exporter)

My linux and Perl version is as below

NAME="Red Hat Enterprise Linux Server"
VERSION="7.6 (Maipo)"

This is perl 5, version 16, subversion 3 (v5.16.3) built for x86_64-linux

My answer:


The missing packages are in the RHEL optional channel, which you need to enable first.

subscription-manager repos --enable=rhel-7-server-optional-rpms

When using RHEL on AWS, enable it this way instead:

yum-config-manager --enable rhui-REGION-rhel-server-optional

View the full question and any other answers on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.