ubuntu upgrade apt conflicts using apt

mangusbrother asked:

I have a ubiquity xg-server which i just upgraded from ubuntu 16 to 18

i noticed a lot of stuff got disabled mainly due to being 3rd party repos.
I reenabled the ones i had and started to enable all my software.

I am getting this error however:

[email protected]:/tmp$ sudo apt-get install mongodb-server
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 mongodb-org : Depends: mongodb-org-server but it is not going to be installed
               Depends: mongodb-org-mongos but it is not going to be installed
               Depends: mongodb-org-tools but it is not going to be installed
               Conflicts: mongodb-server but 1:3.6.3-0ubuntu1.1 is to be installed
 mongodb-org-shell : Conflicts: mongodb-server but 1:3.6.3-0ubuntu1.1 is to be installed
 mongodb-server : Depends: mongodb-clients but it is not going to be installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
[email protected]:/tmp$ sudo apt-get autoremove
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt --fix-broken install' to correct these.
The following packages have unmet dependencies:
 mongodb-org : Depends: mongodb-org-server but it is not installed
               Depends: mongodb-org-mongos but it is not installed
               Depends: mongodb-org-tools but it is not installed
 unifi-video : Depends: mongodb-10gen (>= 2.4.10) but it is not installable or
                        mongodb-org-server (>= 2.6.0) but it is not installed or
                        mongodb-server (>= 2.4.9) but it is not installed
E: Unmet dependencies. Try 'apt --fix-broken install' with no packages (or specify a solution).
[email protected]:/tmp$ sudo apt --fix-broken install                                                  Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
The following packages were automatically installed and are no longer required:
  libboost-filesystem1.65.1 libboost-iostreams1.65.1 libboost-program-options1.65.1
  libboost-system1.65.1 libstemmer0d mongo-tools mongodb-server-core
Use 'sudo apt autoremove' to remove them.
The following additional packages will be installed:
  mongodb-org-mongos mongodb-org-server mongodb-org-tools
The following NEW packages will be installed:
  mongodb-org-mongos mongodb-org-server mongodb-org-tools
0 upgraded, 3 newly installed, 0 to remove and 0 not upgraded.
2 not fully installed or removed.
Need to get 0 B/63.1 MB of archives.
After this operation, 226 MB of additional disk space will be used.
Do you want to continue? [Y/n] Y
(Reading database ... 111690 files and directories currently installed.)
Preparing to unpack .../mongodb-org-server_4.0.9_amd64.deb ...
Unpacking mongodb-org-server (4.0.9) ...
dpkg: error processing archive /var/cache/apt/archives/mongodb-org-server_4.0.9_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/mongod', which is also in package mongodb-server-core 1:3.6.3-0ubuntu1.1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Preparing to unpack .../mongodb-org-mongos_4.0.9_amd64.deb ...
Unpacking mongodb-org-mongos (4.0.9) ...
dpkg: error processing archive /var/cache/apt/archives/mongodb-org-mongos_4.0.9_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/mongos', which is also in package mongodb-server-core 1:3.6.3-0ubuntu1.1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Preparing to unpack .../mongodb-org-tools_4.0.9_amd64.deb ...
Unpacking mongodb-org-tools (4.0.9) ...
dpkg: error processing archive /var/cache/apt/archives/mongodb-org-tools_4.0.9_amd64.deb (--unpack):
 trying to overwrite '/usr/bin/bsondump', which is also in package mongo-tools 3.6.3-0ubuntu1
dpkg-deb: error: paste subprocess was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/mongodb-org-server_4.0.9_amd64.deb
 /var/cache/apt/archives/mongodb-org-mongos_4.0.9_amd64.deb
 /var/cache/apt/archives/mongodb-org-tools_4.0.9_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

I noticed of interest: Conflicts: mongodb-server but 1:3.6.3-0ubuntu1.1 is to be installed

How can I solve this?

My answer:


You’ve previously installed an older version of MongoDB, 3.6.3, packaged by Ubuntu, and this is already installed. But now you are trying to install a MongoDB 4.0.9 packaged by mongodb.org which uses different package names. The conflict arises because they are packaged differently.

To resolve the problem, remove the existing MongoDB packages from your system, and after that, install the new MongoDB packages.


View the full question and any other answers on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.