install msmtp amazon linux

TheStoryCoder asked:

My goal is to get the PHP mail() function to work on Amazon Linux. So the best option seems to be to install msmtp (found in EPEL repository) but I get a dependency error.

I run run sudo yum --enablerepo=epel install msmtp but then get:

Loaded plugins: priorities, update-motd, upgrade-helper
1053 packages excluded due to repository priority protections
Resolving Dependencies
--> Running transaction check
---> Package msmtp.x86_64 0:1.4.32-1.el6 will be installed
--> Processing Dependency: libgsasl.so.7(LIBGSASL_1.1)(64bit) for package: msmtp-1.4.32-1.el6.x86_64
--> Processing Dependency: libgnome-keyring.so.0()(64bit) for package: msmtp-1.4.32-1.el6.x86_64
--> Processing Dependency: libgsasl.so.7()(64bit) for package: msmtp-1.4.32-1.el6.x86_64
--> Running transaction check
---> Package libgsasl.x86_64 0:1.4.0-4.el6 will be installed
--> Processing Dependency: libntlm.so.0()(64bit) for package: libgsasl-1.4.0-4.el6.x86_64
---> Package msmtp.x86_64 0:1.4.32-1.el6 will be installed
--> Processing Dependency: libgnome-keyring.so.0()(64bit) for package: msmtp-1.4.32-1.el6.x86_64
--> Running transaction check
---> Package libntlm.x86_64 0:1.3-2.2.amzn1 will be installed
---> Package msmtp.x86_64 0:1.4.32-1.el6 will be installed
--> Processing Dependency: libgnome-keyring.so.0()(64bit) for package: msmtp-1.4.32-1.el6.x86_64
--> Finished Dependency Resolution
Error: Package: msmtp-1.4.32-1.el6.x86_64 (epel)
           Requires: libgnome-keyring.so.0()(64bit)

These are the details of the Amazon Linux instance:

NAME="Amazon Linux AMI"
VERSION="2018.03"
ID="amzn"
ID_LIKE="rhel fedora"
VERSION_ID="2018.03"

According to /etc/yum.repos.d/epel.repo it uses EPEL 6.

My answer:


EPEL is not compatible with Amazon Linux. If you need to use packages from EPEL, you need to use a distribution compatible with it, such as CentOS or RHEL.


View the full question and any other answers on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.