Error while installing phabricator using

Saurav Shah asked:

The command thats run is

yum install httpd git php php-cli php-mysql php-process php-devel php-gd php-pecl-apc php-pecl-json mysql-server

I get these errors.
How do I fix these?

Error: Package: php-devel-5.3.3-3.el6_2.6.x86_64 (rhel6-optional)
       Requires: php = 5.3.3-3.el6_2.6
       Available: php-5.3.3-3.el6.x86_64 (rhel6-base)
           php = 5.3.3-3.el6
       Installing: php-5.3.3-14.el6_3.x86_64 (rhel6-updates)
           php = 5.3.3-14.el6_3
Error: Package: php-process-5.3.3-3.el6_2.6.x86_64 (rhel6-optional)
       Requires: php-common = 5.3.3-3.el6_2.6
       Available: php-common-5.3.3-3.el6.x86_64 (rhel6-base)
           php-common = 5.3.3-3.el6
       Installing: php-common-5.3.3-14.el6_3.x86_64 (rhel6-updates)
           php-common = 5.3.3-14.el6_3

My answer:

Your system seems to be trying to mix packages from RHEL 6.0, 6.2 and 6.3. This isn’t going to work very well.

My first thought is that your yum caches are stale. Try cleaning them before you install the packages again:

yum clean all

Second, make sure you have set a Red Hat release for the system:

subscription-manager release --set=6.3
yum distro-sync

If you still can’t get the packages installed, contact Red Hat. You have a subscription; you may as well get your money’s worth from it!

View the full question and any other answers on Server Fault.

Creative Commons License
This work is licensed under a Creative Commons Attribution-ShareAlike 3.0 Unported License.